Hilfe - Suche - Mitglieder - Kalender
Vollansicht: Programme Automatisch mit Proton öffnen
HTML-Editor phase 5 Support > Fragen, Lösungen zu HTML-Problemen bzw. Webdesign-Fragen - Talk > Proton
Rigo
Hallo smile.gif

Ich habe leider ein Problem - und zwar wenn ich z.B. PHP Dateien Automatisch mit Proton öffnen lassen will klappt das ganze nicht.

Ich klicke auf eine PHP Datei rechts => Öffnen mit => Programm asuwählen...

Nun muss ich noch auf Durchsuchen klicken da Proton noch nicht in der Liste auftaucht - nun wähle ich die Proton.exe aus und klicke auf "Öffnen".

Leider steht dann in der Liste nicht Proton zur Auswahl - so wie es Eigentlich sein sollte.

Früher ging es immer aber Irgendwie nicht mehr. Hat einer eine Idee? Oder weiß einer wie ich das ganze ansonsten machen kann?
Conny
Hi Rigo,
mache mal folgendes:
1.) Proton öffnen.
2.) oben in der Leiste, klick auf Ansicht.
3.) Reiter 'Setup & Installation' auswählen
4.) unter: 'Eintrag im Popupmenü des Windows-Dateimanagers' zusätzlich den Eintrag 'PHP' vornehmen...

Das mußte es gewesen sein :wink: .

Conny
Rigo
Genau das habe ich auch schon vermutet - aber leider geht das nicht.

Wenn ich unter "Ansicht => Programmeinstellungen => Karteikarte Setup & Installation" unten einen neuen Punkt eingebe - wie beschrieben z.B. PHP (php - egal wie man es schreibt) wird dies nicht Übernommen.

Ich kann auf Ok klicken - dann wieder dort ins Menü klicken und der Eintrag ist nicht vorhanden. Wenn ich dort alles entferne - dann auf OK klicke und wieder in das Menü gehe sind auch alle Einträge weiterhin vorhanden.

Der Button "Übernehmen" unterhalb und neben OK und Abbrechen bleibt auch "nicht anklickbar" wink.gif
helpy
Hi Rigo,

Ich hab' das bei mir ausprobiert. und die gleiche Erfahrung gemacht wie Du.

Versuch folgendes:[list]Im Explorer-Menü: Extras=>Ordneroptionen...

[*]Reiter: Dateitypen

[*]Suche den Eintrag PHP und markiere ihn

[*]Bei mir war dann die Schaltfläche Wiederherstellen

[*]Als ich die angeklickt hatte, war der Proton-Eintrag im Kontext-Manü da

[*]ABER: Der Eintrag "Bearbeiten mit Html-Editor" war dann weg :-([list]
Was da genau passiert ist ... kann ich noch nicht sagen ... werd' mir das mal irgendwann ansehen...

cu, helpy
Rigo
Das geht leider bei mir nicht... Schade sad.gif

Was auch merkwürdig ist - ich habe im Menü (bei Öffnen mit) 2 mal den Windows Editor stehen... wink.gif
Conny
@ Rigo,

Einweiterer Versuch.
Ähnlich wie Helpy es beschreibt:

[list]Im Explorer-Menü: Extras=>Ordneroptionen...
Reiter: Dateitypen
Suche den Eintrag PHP und markiere ihn
Klick auf Button Bearbeiten (es öffnet sich ein neues Fenster)
Im Feld Vorgänge steht fett Offnen (und vielleicht noch weitere Einträge).
Ausser Öffnen (in Fettschrift) alles andere eins nach dem andern markieren und auf entfernen klicken. (So wirst Du auch den doppelten Eintrag los)
Öffnen markieren und Button Bearbeiten klicken.
Im Feld 'Anwendung für diesen Vorgang' den vorhandenen Pfad mit dem Pfad zur Proton ergänzen.[list]

Conny
Rigo
Also bei mir (Windows XP) sieht das ganze etwas anders aus - daher finde ich die Punkte die du beschrieben hast auch nicht sad.gif
Conny
Schade, da hat good old Win98 so seine Vorteile :wink:
Aber es gibt hier im Forum sicherlich noch ein paar XP Experten
(Andreas oder Dieter?),
die wissen wo man diese Einstellungen unter XP machen kann.

Conny
Rigo
So ganz doof bin ich ja auch nicht, aber ich habe alles ausprobiert - einstellungen hin und her getestet aber nichts will klappen.

Früher ging das ganze ja mal - und nun als ich Proton wieder gebraucht habe (für mein eigenes Forum) hab ich bemerkt das es auf diesem (anderen) Rechner nicht geht. Und der alte Rechner war auch mit Windows XP Pro bestückt wink.gif
i.b.g
Hallo!

Rigo, das was Conny und Helpy Dir mitteilen wollen ( ich will jetzt nicht an Dir zwiefeln biggrin.gif ) ist einfach, mit den Mitteln von Windows den Dateityp von PHP mit Proton für die Aktion Öffnen zu verknüpfen. Ich kann Dir da auch nicht sagen, wie es bei XP geht, denn ich hab nur W2K und WIN98. Aber ich kann mir nicht vorstellen, das M$ das so sehr abweichend vom Rest der WIN-Family in XP geregelt hat. Unter den NT-basierten Systemen ist es sogar noch logischer, da dort die Dateierweiterungen geführt werden und nicht irgendwelche Beschreibungen, die sich sowieso keiner merkt.
Vielleicht ist die Konsulation der WIN-Hilfe angebracht, wo Du einfach mal nach Dateitypen suchst und das Thema "Verbinden von Dateitypen mit Programmen" anschaust.

Good Luck!
Rigo
Wie ich schon sagte - ich habe alles schon ausprobiert nur leider wird Proton immer wenn ich es mit einer PHP Datei verknüpfen will nicht in der Liste angezeigt. So kann ich es dann auch nicht auswählen.

Ich habe zwar schon im Menü (Rechts auf eine Datei klicken) das "Bearbeiten mit Proton" aber ich möchte halt das sich die Dateien auch Automatisch mit Proton öffnen - nur das klappt imho noch nicht
helpy
aaaaah ... das meinst Du. [list]In den Ordneroptionen auf den Reiter Dateitypen klicken.

[*]In der Liste den gewünschten Dateityp auswählen

[*]Auf die Schaltfläche Erweitert klicken

[*]In der Liste Vorgänge den Eintrag für Proton auswählen

[*]Dann auf die Schaltfläche "Als Standard" klicken

[*]2 x OK klicken[list]Das sollte es gewesen sein ...

cu, helpy

Nachtrag 1: Damit wird die Datei bei einem Doppelklick im Explorer mit Proton geöffnet.
i.b.g
Hallo!

ZITAT
Wie ich schon sagte - ich habe alles schon ausprobiert nur leider wird Proton immer wenn ich es mit einer PHP Datei verknüpfen will nicht in der Liste angezeigt. So kann ich es dann auch nicht auswählen.


Auch von mir nochmal ein aha!

Wenn man mit einem Rechtsklick auf die Datei im Kontextmenü auf "Öffnen mit" geht, dann erscheint die Liste der Programme, die zum Zuweisen zur Verfügung stehen. Nicht alle sind dort aufgeführt. Unten in diesem Fenster steht aber ein Button "Andere". Nach einem Klick hier erhält man ein Standard-Öffnen-Fenster, wo man zum Verzeichnis zu proton navigieren kann, um proton.exe als zuzuordnendes Programm zu wählen. Ich denke das ist's, was Du meinst? smile.gif
Rigo
Ja genau das meine ich - und genau das Funktioniert ja bei mir nicht. Wenn ich auf Öffnen mit => Programm auswählen... klicke und dort dann unter Durchuchen die proton.exe auswähle und das ganze wiederrum mit Öffnen bestätige wird Proton trotzdem nicht in der Liste angezeigt.

Das ist ja mein Problem wink.gif
i.b.g
Hallo!

Wie gesagt, ich hab kein XP. aber hast Du schon mit den Zugriffsrechten experimentiert. Eventuell darf unter XP nur der Administrator solche Aktionen durchführen. Ansonsten fällt mir dann nichts mehr ein.

Hat denn der Vorschlag von Helpy geholfen?
Rigo
Haaaa Tatsächlich - so klappt das... smile.gif

Halt etwas umständlich aber so gehts tatsächlich...

Aber fragt mich nicht wieder das auf die andere weise nicht geht - sehr Komisch... Werde nach dem Fomatieren der neuen Festplatte nochmal Windows neu Installieren und mal schauen ob es dann wieder geht smile.gif

Danke zumindest für eure Hilfe smile.gif
Al-Pi
Hallo zusammen,

habe bislang zum editieren von .html und .php dateien immer Proton angewendet.
Das Proton32de Verzeichnis befand sich auf einer 2. festplatte (D:) was vor kurzem kaputt gegangen ist und daher ausgebaut werden musste.

Nun habe ich den aktuellsten version runtergeladen und auf C: entpackt,
leider kann ich nicht mehr das befehl öffnen mit geben.
Kurz ich gehe auf einer php datei mit der rechten maustaste > öffnen mit > Programm auswählen > durchsuchen /proton32de/proton.exe
nur passiert da nicht...(mehr) (In der liste der empfohlenen Programe oder andere programme wird proton nict angezeigt)

ich kann nur noch die dateien öffnen, indem ich proton starte und über Datei > öffnen das gewünschte dokument anwähle.
das ist aber leider sehr umständlich, hat vllt jemand eine idee (tip) wie ich es wieder mit der rechten maustaste öffnen kann.

Benutze windows xp home sp2

mfg
alpi
Thomas
ZITAT(Al-Pi @ 29.07.2007 - 11:18) *
Kurz ich gehe auf einer php datei mit der rechten maustaste > öffnen mit > Programm auswählen > durchsuchen /proton32de/proton.exe

Genau so sollte es gehen: Im Durchsuchen-Dialog suchst du auf Platte C: das Verzeichnis, in dem die proton.exe steht und wählst sie aus. Wenn deine Beschreibung allerdings meint, dass du den Pfad "/proton32de/proton.exe" von Hand eingibst, dann kann es durchaus sein, dass es nicht funktioniert, weil einfach der von dir eingegebene Pfad nicht existiert. Hilft dir das weiter?
Al-Pi
Hallo Thomas,

danke erstmal für deine Antwort...
leider öffnet proton nicht die dateien wie es öffnen sollte,
hatte das gleiche problem auch mal mit , meinen power dvd gehabt,
es blieb mir nichts anderes übrig wie windows neu zu installiern unsure.gif

hatte gehofft dass eine andere lösung geben würde...
habe mal es mit einen anderen neuen editor versucht, damit klappt es.
doch auf proton würde ich nicht verzichten wollen, es ist einfach nur genial icon13.gif
i.b.g
Hallo,

liegen die zu bearbeitenden Dateien eventuell in einem Ordner, dessen Name Leerzeichen enthält? (z.B. "Eigene Dateien") Dann könnte das Leerzeichen der Grund sein, dass das Öffnen nicht mehr so funktioniert, wie Du es erwartest. Versuche mal einen Ordner anzulegen, dessen Name keine Leerzeichen enthält, kopiere das Projekt dort hin und versuche nun, die Dateien in der gewohnten Weise zu öffnen. Vielleicht hilft's ja.
Thomas
Was schreibt denn der Explorer in der Spalte Typ hinter den PHP-Dateien? Falls du dich ein bisschen mit Windows auskennst, kannst du unter "Extras" / "Ordneroptionen" / "Register 'Dateitypen'" nach der Endung PHP suchen und prüfen, was da eingetragen ist. Eventuell kannst du an dieser Stelle etwas ändern. Oder du musst über die Registry gehen - aber wirklich nur, wenn du dich damit auskennst.
Al-Pi
Danke an allen die mir dabei geholfen haben.

ich habe über start > ausführen/regedit proton gesucht und den verzeichnis ganz gelöscht
danach konnte man wieder alle datein (html, php usw) über rechtsklick mit proton öffnen !
andere editoren--> firefox_love.gif <-- proton
Dieses ist eine vereinfachte Darstellung unseres Foreninhaltes. Um die detaillierte Vollansicht mit Formatierung und Bildern zu betrachten, bitte hier klicken.
Invision Power Board © 2001-2023 Invision Power Services, Inc.